Home Forums Plugins Store Exporter Deluxe [Resolved] Little bug with Scheduled Exports

This topic contains 8 replies, has 2 voices, and was last updated by  Michael Visser 2 years, 4 months ago.

Welcome to our community support forums! We're here to help - but if you have an urgent request for a Pro Plugin, you will get a prioritised response through our Premium Support page.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #46433

    Dima
    Participant

    Each time you edit a “Scheduled Export”, the “Frequency” will revert to daily, so need to set it each time to what is needed. We have encountered this with option “One Time”, I am sure its with others as well.

    #46434

    Dima
    Participant

    Tested again, it actually happens only with “One Time”.
    It seem like there is no option to edit/update my previous post here. Is it intentional?

    #46440

    Michael Visser
    Keymaster

    Re the forums: Hi Dima, it’s run of the mill bbPress you should be able to edit your own topics/posts. If a Plugin for bbPress is required to allow users to edit their own topics/posts I’ll get it added.

    The “one time” Frequency is a little special as it only schedules a single event using wp_schedule_single_event() instead of wp_schedule_event(). I’ll reproduce this and see what’s going on as we do some frequency value checks at saving time on the Edit Scheduled Export screen to reset the Scheduled Export WP_CRON task as needed.

    #46443

    Dima
    Participant

    Re the forums: I am not finding any button to edit my posts)) Maybe you should login as regular user and check it out.
    –> Strangest thing: I can edit this reply, but nothing else. ??
    –> Ha! The “edit” button appears only for replies that are made after your reply on the topic. This is amusing lol

    “one time” – from what I have seen its nothing complicated there. Its just seem to not grab this option “one time”, so when you open the Scheduled Export template another time to do some changes, no option of “Frequency” is chosen. I think you missed this get_option or something. So since nothing chosen it reverts to its default which is “daily” when saved.

    #46444

    Michael Visser
    Keymaster

    bbPress… 🙁 It’s up to date and there’s no moderation queue unless Akismet flags it, I’ll have a look at what’s going on here at visser.com.au tomorrow; Friday play day.

    Re: “one-time” line #1880 of includes/scheduled_export.php, it looks the WordPress Option woo_ce_auto_schedule is defaulting to ‘daily’ where a FORM value is not sent, it also will not save any change of value if there’s been no change to woo_ce_auto_schedule, woo_ce_auto_interval, woo_ce_auto_commence or woo_ce_auto_commence_date.

    I’ll reproduce this and see if I can catch it in the act. I bet it’s a empty FORM value rather than the validation checking. I’ll have more news shortly 🙂

    #46445

    Dima
    Participant

    One more for you: I now cannot edit my previous reply, which is after you replied. So it does seem intentional not to edit the “already read” replies. But new posts before being replied I think should have edit option.

    #46446

    Michael Visser
    Keymaster

    Found the “Disallow editing after” option within Settings > Forums, I cranked that way up from the default 15 minutes to 1440 minutes (24 hours) which should resolve this. I’ll try it on a new topic as a Participant User Role to confirm.

    I’m looking at the Frequency option not saving now 🙂

    #46448

    Michael Visser
    Keymaster

    Hi Dima, yup, confirmed that topic edit issue is fixed using the above “Disallow editing after” change.

    #46466

    Michael Visser
    Keymaster

    Hi Dima, I did a whole bunch of testing how woo_ce_scheduled_export_save() worked then realised there was no checked() on the One time radio button value… I’ll get that into the next Plugin release due Monday/Tuesday. If you need an early release ping me on Support 🙂

    https://www.visser.com.au/premium-support/

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘[Resolved] Little bug with Scheduled Exports’ is closed to new replies.