Search Documentation

Download Expiry works with the following WordPress e-Commerce plugins:

  • WP e-Commerce

Support

Download Expiry comes with a Quick Start document (readme.txt) to help with installing the Plugin. Additional support can be found in the Download Expiry forum, or the Contact page.

Urgent Support

If you find yourself needing immediate support for your purchase, please use the Premium Support page.

Download Expiry Forum

If you have any problems, questions or suggestions please join the members discussion on our Download Expiry forum.

Readme

View the quick start document (readme.txt) that accompanies Download Expiry.

View the Readme

*** This readme must accompany the Plugin at all times and not to be altered or changed in any way. ***

=== Download Expiry for WP e-Commerce ===

Contributors: Michael Visser
Tags: e-commerce, shop, cart, ecommerce, download expiry
Requires at least: 2.9.2
Tested up to: 3.2.1
Stable tag: 1.2.4

== Description ==

Provide electronic purchases to customers on a time-based expiry model within WP e-Commerce.

For more information visit: http://www.visser.com.au/wp-ecommerce/

== Installation ==

1. Upload the folder 'wp-e-commerce-download-expiry' to the '/wp-content/plugins/' directory

2. Activate 'Download Expiry for WP e-Commerce' through the 'Plugins' menu in WordPress

3. Copy the following snippet and paste it below "$products = $wpdb->get_results( $sql, ARRAY_A );" on line #321 in /wp-content/plugins/wp-e-commerce/wpsc-theme/functions/wpsc-user_log_functions.php

$products = apply_filters( 'wpsc_has_downloads_products', $products );

4. That's it!

Note: Step 3 will not be required in future WP e-Commerce Plugin updates as a patch has been provided to GetShopped.org.

== Support ==

If you have any problems, questions or suggestions please join the members discussion on my WP e-Commerce dedicated forum.

http://www.visser.com.au/wp-ecommerce/forums/

== Disclaimer ==

It is not responsible for any harm or wrong doing this Plugin may cause. Users are fully responsible for their own use. This Plugin is to be used WITHOUT warranty.

Version History

See what’s changed in each release of the Plugin.

View the Changelog

== Changelog ==

= 1.2.4 =
* Fixed: WP e-Commerce Plugins widget markup
* Changed: Using clicked()
* Changed: Standardised Products Page/Single Product

= 1.2.3 =
* Fixed: Styling issue within Plugins Dashboard widget

= 1.2.2 =
* Added: Alt. switch to wpsc_get_action()

= 1.2.1 =
* Fixed: Issue introduced with wpsc_get_action()

= 1.2 =
* Fixed: First time activation not firing
* Fixed: Performance improvements for WP e-Commerce Plugins widget
* Added: Automatic Plugin updates

= 1.1 =
* Added overrite for My Downloads
* Added settings page

= 1.0.1 =
* Moved ..._check_plugin_version() to functions.php
* Migrated Plugin prefix from 'vl_wpscde' to 'wpsc_de'

= 1.0 =
* First working release of the Plugin

== Disclaimer ==

It is not responsible for any harm or wrong doing this Plugin may cause. Users are fully responsible for their own use. This Plugin is to be used WITHOUT warranty.

Wishlist

Visit the Download Expiry Ideas forum to see what’s in the works for future Plugin releases.

Plugin Updates

The latest release can be downloaded from your My Account page.